别用 Hyper-V 第二代虚拟机安装加密磁盘的 Debian」的摘要信息

昨晚尝试用安装全盘加密的 Debian 虚拟机,安装时一切正常,装完后启动发现无法输入磁盘密码,导致无法启动。网上搜索一番,发现是 Debian 在解密磁盘时还没加载 Hyper-V 的键盘驱动,导致无法输入: Because Generation 2 virtual machines in Hyper-V are presented with a minimal set of EFI hardware, the kernel module “hyperv_keyboard” must be present to interact with the console keyboard. On systems with disk encryption, the user will be prompted for the key to decrypt the disk, but cannot enter the password because no keyboard driver is present. 此问题不仅在 Debian 存在: Debian:Unlocking LVM under Hyper-V Kaki:[Hyper-V] hyperv_keyboard module needed for Generation 2 VMs 可能还有些其他 Linux 发行版存在这种问题。当然也有解决办法: You would have to boot the installer > then chroot into the installed system ( wherever the root filesystem is in hyper-V) and then edit /etc/initramfs-tools/modules 但我不知道怎么 chroot into... ,...